QuickBooks Online server outage

Incident Report for ShipRush

Resolved

Intuit is now reporting this issue as resolved, and ShipRush is no longer seeing errors. Please reach out to support if you continue to see trouble.
Posted May 14, 2025 - 13:47 PDT

Update

Updates from Intuit can also be found here: https://status.quickbooks.intuit.com/
Posted May 14, 2025 - 10:08 PDT

Identified

QuickBooks Online is currently experiencing a server outage, preventing some users from getting new invoices, or from shipped invoices from updating successfully. Intuit support is aware of the issue and working to resolve it now, we will provide updates here once it has passed.
Posted May 14, 2025 - 10:01 PDT
This incident affected: Ecommerce connectivity.