UPS Server Interruption

Incident Report for ShipRush

Resolved

There may still be some slowness, but most users should be able to ship again with UPS without issue.
Posted May 13, 2025 - 13:09 PDT

Monitoring

UPS is still experiencing periodic timeouts and delays, but many shipments are processed successfully. If you receive an error, please try your shipment again in a few minutes.
Posted May 13, 2025 - 12:36 PDT

Identified

UPS Servers are currently experiencing a partial outage, resulting in timeout and other errors when rating and shipping. Their support team is aware of the issue and working to resolve it now.

We will post updates here as they are available.
Posted May 13, 2025 - 11:25 PDT
This incident affected: Carrier Functionality.