FedEx Outage
Incident Report for ShipRush
Resolved
FedEx servers appear to be stable again, though some users may see lingering errors when rating and shipping. If so, wait a few moments and try your shipment again.
Posted Jan 13, 2025 - 12:28 PST
Identified
FedEx servers are currently experiencing a general outage, affecting all web shippers. This is causing slowness and various errors when attempting to rate & ship FedEx services.

Their support is aware of the issue and working to resolve it now, we will post updates here as they are available.
Posted Jan 13, 2025 - 10:28 PST
This incident affected: Carrier Functionality.