Amazon Outage

Incident Report for ShipRush

Resolved

Amazon reports this issue should largely be resolved. Some users may see lingering delays as systems catch up.
Posted Oct 20, 2025 - 13:54 PDT

Identified

Amazon Servers are currently experiencing an outage, causing slowdowns and errors in ShipRush for Amazon related processes like order management and Amazon shipping.

Their support is aware of the issue and working to resolve it now, we will post an update here once we have confirmation it is fixed.
Posted Oct 20, 2025 - 08:14 PDT
This incident affected: Carrier Functionality and Ecommerce connectivity.